eService: The remote name could not be resolved: 'localhost'

Feb 23, 2010 at 2:42 AM

I successfully installed the eServices Full Sample Portal into my Server's IIS and I'm able to access everyting via http://localhost:4444/default.aspx while connected inside my network.

Then, I copied the entire Full Sample Portal to my web hosting company's server (Network Solutions) so I could verify that it would work outside of my network. When I click on "Customer Service" on the Fabrikam Inc. website I get the following error:

 

Server Error in '/' Application.


The remote name could not be resolved: 'localhost' 

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Net.WebException: The remote name could not be resolved: 'localhost'


Source Error:

Line 111:               try

Line 112:               {

Line 113:               Microsoft.Crm.SdkTypeProxy.RetrieveMultipleResponse retrieveResponse = (Microsoft.Crm.SdkTypeProxy.RetrieveMultipleResponse)service.Execute(retrieveRequest);

Line 114:               foreach (Microsoft.Crm.Sdk.BusinessEntity entity in retrieveResponse.BusinessEntityCollection.BusinessEntities)

Line 115:               {


Source File: e:\0\1\60\90\1875742\user\2038272\htdocs\Global.asax    Line: 113

Stack Trace:

[WebException: The remote name could not be resolved: 'localhost']

   System.Net.HttpWebRequest.GetRequestStream() +5322142

   System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) +103

   Microsoft.Crm.SdkTypeProxy.CrmService.Execute(Request Request) +50

   ASP.global_asax.RetrieveConfiguration(CrmService service, QueryBase query) in e:\0\1\60\90\1875742\user\2038272\htdocs\Global.asax:113

   ASP.global_asax.Cache_eService_FullConfig() in e:\0\1\60\90\1875742\user\2038272\htdocs\Global.asax:31

   ASP.global_asax.Application_Start() in e:\0\1\60\90\1875742\user\2038272\htdocs\Global.asax:12

 

I believe my error is with my connectionString within the web.config file to connect to my SQL 2008 Server. How should I write the connectionString in order to access my SQL 2008 Server? Here's what's in my web.config now:

<connectionStrings>
  <remove/>
  <remove/>
  <add connectionString="Data Source=.\SQLExpress;integrated security=true;attachdbfilename=|DataDirectory|SmallCompanyDB.mdf;user instance=true"/>
  <!--This setting is for the asp.net membership store db-->
  <add connectionString="Server=MERCURY;Database=aspnetdb;integrated security=true;"/>
 </connectionStrings>
 <appSettings>
  <!--
  These settings are for the portal pages and controls to call the
  crm web services. If you are setting this up on the standard vpc image then
  set the domain value to "." if you are having problems.
  -->
  <add key="msa.CRMOrganizationName" value="CSIUilitySales"/>
  <add key="msa.CRMServerUrl" value="http://localhost:5555/MSCRMServices"/>
  <add key="msa.CRMWebServicesUser" value="crmwebuser"/>
  <add key="msa.CRMWebServicesPassword" value="password"/>
  <add key="msa.CRMDomain" value="CRM"/>
 </appSettings>

Can someone please help me resolve this issue?

Feb 24, 2010 at 7:39 PM

Can anyone please help me resolve this issue?

Thank you, Jeff Battley