MSA Goals Graph and Matrix Reports - Forecasting Accelerator

May 12, 2010 at 4:00 PM

I recently installed the the Forecasting Accelerator and I am having trouble getting the two reports, MSA Goals - Graph and MSA Goals - Matrix to run. The first error I received was:

  • An error has occurred during report processing.
    • Query execution failed for dataset 'DSMain'.
      • For more information about this error navigate to the report server on the local server machine, or enable remote errors

So, I changed the connection to point to our server and the connection was successful. However, now when I try to run the reports I get the following error and I'm not sure how to fix this error. I think I need to modify the query but I am not sure how to modify it and I am not sure that modifying it will fix my issue. Any suggestions would be appreciated.

An error occurred during local report processing.

An error has ocurred during report processing.

Query execution failed for dataset 'DSMain'

Must declare the scalar variable "@rpt_OwnerID".

Must declar the scalar variable "@rpt_OwnerID".

Must declar the scalar variable "@rpt_OwnerID".

Incorrect syntax near the keyword 'AND'.

Inccorrect syntax near ')'.

Must declare the scalar variable "@rpt_level".

Jul 19, 2010 at 3:32 PM

have you solved the problem?

Jul 19, 2010 at 3:34 PM

Have you fond a solution to this problem?? Please let me know. Thanks.

Jul 19, 2010 at 3:48 PM

Yes, we were able to solve the problem. The code in the reports had inconsistant uses of case while refering to database objects such as field names. This is fine as long as the Db is case insensitive but not when it is case sensitive becase the code errors out because it can't find the object

Jul 19, 2010 at 4:10 PM

my DB is not case sensitive. Could you please paste the SQL code in dsMain?


Jul 19, 2010 at 5:03 PM

I had to turn those SQL statement to Stored Procedure and use that procedure instead of SQL code. But I am having problem with setting value to a internal parameter "CRM_Filteredmsa_goal" but if I open it then report works fine.