This is the Default.aspx page. The URL rewriting may not be configured correctly.

Aug 30, 2010 at 2:41 PM

When I try to access the portal site, I receive the error:

"This is the Default.aspx page. The URL rewriting may not be configured correctly."

Has anyone experienced this?  What needs to be done to rectify the situation?

Aug 30, 2010 at 2:57 PM

Are you hosting the site on IIS 6?  If so, have you set the custom 404 error to redirect to url /default.aspx?   This is an additional step that is required for hosting on the legacy Windows 2003 / IIS 6 environment.  This instruction was accidentally left out of the installation guide, but will be included in the next drop.

Shan McArthur
www.shanmcarthur.net

Aug 30, 2010 at 3:01 PM

Shan,

The site is hosted on IIS6, and i have set the custom 404 error to be the url /default.aspx, and have this issue despite this

 

 

Aug 30, 2010 at 4:08 PM

Are you hiting the url explicitly, or are you letting IIS naturally handle it?  ie:  http://mysite/default.aspx  or http://mysite/

If you hit it explicity, then that is expected behavior.  If it is being redirected there, then one of your http modules is not registered properly in your web.config.  You need a physical page there for this to work, but it doesn't have to be default.aspx, it can be some non-guessable page.

Shan

Aug 30, 2010 at 4:11 PM

Letting IIS handle it:  http://mysite/portal  is where it is located... can it not be in a slash directory like that?

I'll look into the HTTP modules

 

Jay

Aug 30, 2010 at 4:22 PM

The portal has to be run at the root of your website.  You cannot run the portal under a virtual directory or application.  For example, http://mysite/portal  is not a supported configuration.

Shan

Aug 30, 2010 at 4:35 PM

I moved the portal to the root of my site and everything seems to be working wonderfully now.

 

Thanks a bunch Shan

Oct 18, 2011 at 5:57 AM
Edited Oct 18, 2011 at 5:59 AM

Hi shan,

I'm using customer portal 2011 configured in IIS 7. I have set the custom 404 error to redirect to url /default.aspx. Then published solution have  move to wwwroot directory. After browsing my portal i.e. http://localhost:8888/pages, 

the website  main is running properly. when i open any other links i.e. http://localhost:8888/ cases, the page was redirect. But sub pages is not displayed.

Rewrite url. ~/Pages/eService/ViewCases.aspx. How to solve  this rewrite url.?

please help me very urgent.

 

Lings

Oct 18, 2011 at 1:41 PM

This codeplex project is for the support of CRM 4 versions of the portals.  The CRM 2011 version of the portals are supported on this forum: http://social.microsoft.com/Forums/en-US/crmlabs/threads

If you are using IIS 7, please check that you are using an application pool that is set to integrated pipeline mode.  If you do that, you do not have to specifically set a 404 error page - all of the settings that are necessary are in the web.config file.

You are showing some urls that are in the visual studio solution, which means that you don't really understand how the url resolution works.  You should never see urls like /pages or ~/Pages/eService/ViewCases.aspx in the website itself - only in the Visual Studio project and as urls in the CRM data entity "Page Templates".  Other than that, you will see content-managed urls in your portal like /cases, which resolve to a Web Page with a partial url called "cases" that is a child of the root home page.