CRM 4 E-service. Can't edit contact's profile from webform

May 26, 2011 at 10:30 AM

Dear all..

I succesfully installed CRM 4 E-Service accelerator . Everything is working fine.. user registration, create case, attach documents, add notes, ... except the Modify Profile form.

When I open the ModifyProfile.aspx page, all fields in the form are read only, alltough the save button is active.

In the eservice configuration, all fields have "IsDisabled = 0"

 

Now the strange this is I even tried commenting the code in ProfileEditor.ascx.cs:

 

if (parentCustomer.statecode.Value == AccountState.Inactive) {

 // accountEditor.ReadOnly = true;

 }

 

I've checked that the parent Customer and contact are both active. My installation is in spanish, so the statecode value for active is "Activo". I've tried in the eservice configuration to put the Statecode to "Activo" and also in english "Active", but still no luck..

 

Any ideas why my ModifyProfile form is read-only?

May 26, 2011 at 3:32 PM

Why are you deploying the eService accelerator?  It was replaced by the Customer Portal accelerator last year.  The eService accelerator is dead.  The customer portal accelerator is built on the xRM portal framework that is shipped with the CRM SDK since 4.0.13.  The portal framework and customer portals have been upgraded to CRM 2011 as well - the eService accelerator will not be.  Please see http://customerportal.codeplex.com/