Workflows not publishing - eService | Event Management 1.1

May 28, 2009 at 10:30 AM

Getting an error (below) when trying to publish most of the Workflows for the above a accelerators.

Any ideas from the error? Very frustrating as this is the final hurdle to getting these configured. Tried creating the workflow from scratch but didn't make a difference.

For the eService only the MSA-eService: Audit Account updates via the eService portal workflow was able to be published.
For the Event Management only the MSA-Event Management: Update Event Address was able to be published.

Any help would be appreciated.

Event Type: Warning
Event Source: ASP.NET 2.0.50727.0
Event Category: Web Event
Event ID: 1309
Date: 28/05/2009
Time: 4:33:47 PM
User: N/A
Computer: VS-STAGING3
Description:
Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 28/05/2009 4:33:47 PM
Event time (UTC): 28/05/2009 8:33:47 AM
Event ID: d62226cd57e3484cb8df2990540601c9
Event sequence: 1401
Event occurrence: 5
Event detail code: 0

Application information:
Application domain: /LM/W3SVC/2/ROOT-1-1288797186261400

06
Trust level: Full
Application Virtual Path: /
Application Path: C:\Program Files\Microsoft Dynamics CRM\CRMWeb\
Machine name: VS-STAGING3

Process information:
Process ID: 2376
Process name: w3wp.exe
Account name: NT AUTHORITY\NETWORK SERVICE

Exception information:
Exception type: TargetInvocationException
Exception message: Exception has been thrown by the target of an invocation.

Request information:
Request URL: https://you005.crm.yourasp.com.au:443/_grid/cmds/dlg_activate.aspx?iObjType=4703&iTotal=1&iIndex=0&iId={F00B4223-72DC-42C5-A800-633F41B8372D}
Request path: /_grid/cmds/dlg_activate.aspx
User host address: 202.155.178.5
User: {2e51d7df-370d-de11-91b4-0003ff1a2306}
Is authenticated: True
Authentication Type: CrmPostAuthentication
Thread account name: NT AUTHORITY\NETWORK SERVICE

Thread information:
Thread ID: 9
Thread account name: NT AUTHORITY\NETWORK SERVICE
Is impersonating: False
Stack trace: at Microsoft.Crm.Application.Utility.Util.RaiseXMLError(Exception exception)
at Microsoft.Crm.Dialogs.ActivateDialogPage.ConfigureForm()
at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
May 29, 2009 at 4:42 PM

We also cannot publish the workflows for the eService 1.1 (except for the Audit Account). Same errors. We attempted to use the installer and it failed with the SOAP error reported in another message. Publishing the workflows problem occurs when we tried to install the eService customizations using Import Customizations from CRM. They seem to import, but the workflows do not publish. The custom entities and contact entity customization seem to import. We did change the "CRM web user" in the workflows. We also notice the web configuration record is not created.

Additional note, the eService1.1 installer did work on the Demo Dynamics CRM virtual machine. But it already had the 1.0 version installed.

Jun 11, 2009 at 9:26 AM

Bounce

Jul 22, 2009 at 10:32 AM

i aslo could not publish workflows. adding the following entry back into my web.config file fixed this for me:
<authorizedType Assembly="mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" Namespace="System.Globalization" TypeName="CultureInfo" Authorized="True"/>

This is a known bug that occurs after you deploy crm hotfix rollup 2 to a server - http://support.microsoft.com/kb/959419

Jan 7, 2010 at 6:04 PM

nzregs,

You are spot on with the resolution to this problem.  Thank you!