eService cannot run with PIA portal

Oct 18, 2009 at 3:42 PM

Hi all,

I'm having a problem runing the eService portal and the PIA portal together!

First I installed eService 1.0 some time ago, and then upgraded to 1.1 without problems. Now I have installed the Portal accelerator which went in fine, but both the Portal and eService Consoles now throw up a simialr error.

Portal Console: The type 'EntityList' is ambiguous: it could come from assembly 'c:\inetpub\wwwroot\bin\MSAConfigurationConsole.DLL' or from assembly 'c:\inetpub\wwwroot\bin\eServiceAccelerator.Web.Configuration.DLL

eService Console: CS0433: The type 'EntityList' exists in both 'c:\WINDOWS\\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\80800253\00f60f6f_ac49ca01\MSAConfigurationConsole.DLL' and 'c:\WINDOWS\\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\97372de3\00479309_9f39c901\eServiceAccelerator.Web.Configuration.DLL'

I know the two accelerators are similar but, they seem to use the same 'EntityList' attribute in two different ways, which seems to make them incompatible.

Has anyone else seen this, or can anyone suggest a fix?



Oct 19, 2009 at 3:16 PM

Hi Chris,

I agree, I've spent the whole day figuring this out, but once I'd rename the eService dll to .old, suddenly the Portal sprang in to life (well, it worked, not literally sprang in to life)




Oct 19, 2009 at 3:16 PM

So yes, I've seen the same error, worked out a bodge, but yes, both will not currently run together, but I'm still working on it