Can't Get Social Networking Installed - Resolved

Oct 21, 2009 at 2:42 PM

I am trying to install the Social Networking Accellerator and the installation crashes on step 4 of 9 (Importing custom assemblies...)

The error is "Value cannot be null.  Parameter name: format."

A snipper from the details of the error reads:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentNullException: Value cannot be null.
Parameter name: format
   at System.String.Format(IFormatProvider provider, String format, Object[] args)
   at System.String.Format(String format, Object arg0, Object arg1, Object arg2)
   at msa_sn_installer.Main.ImportPluginAssemblies(String registerXmlPath, CrmService _crmService, Log log) in C:\Documents and Settings\Administrator\Desktop\SocialNetworking_RTW_R1.0\Source Code\Social Networking Installer\msa_sn_installer\Main.cs:line 1033
   at msa_sn_installer.Main.btnInstall_Click(Object sender, EventArgs e) in C:\Documents and Settings\Administrator\Desktop\SocialNetworking_RTW_R1.0\Source Code\Social Networking Installer\msa_sn_installer\Main.cs:line 133
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

I can't seem to figure out the cause.  I am running CRM on a 64-but server and I did see in the notes that this has not been tested in a 64 bit environment. 

I do choose the option to continue the installation, but it does not appear to contiunue after this error.  Any thoughts of how I can continue this?

I suppose I can register the assemblies manually...but I don't know which ones to register and what the registration values look like.  Maybe someone can export these for me from a working system?

Thanks,

Richard Weck

Harris Technology

Oct 21, 2009 at 3:08 PM

RESOLVED!!!

The user account that I was using to install the integration was not a deployment admin.  I should have realized this when it was failing during the registraiton of the plugins.

Thanks,

Richard Weck

Harris Technology

Feb 16, 2010 at 1:15 AM

I'm getting the same error you have described, along with a http status 401 error unauthorised message at each step until I get to 4 where it fails.

I'm using the domain admin account I used to install CRM, its the deployment account, it has full CRM admin privs.

Its server 2008 r2 64 bit, sql 2008std, crm workgroup edition 64bit.

The admin account was assigned full SQL rights when creating the instance (add current user function)

I have the server setup for IDF and on premise, both working fine.

no errors showing in the app logs or debug folder I created on the c: drive as per the installation video.

I'm running the installation as admin (right click run as admin)

Any ideas?

 

Nov 29, 2010 at 3:41 AM

dudditz,

Did you find an answer?  I have the same config with the same 401 error.

---------------------------
Installation Error
---------------------------
...Error importing custom entities. Message: The request failed with HTTP status 401: Unauthorized.. Stack Trace:    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)

   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)

   at Microsoft.Crm.SdkTypeProxy.CrmService.Execute(Request Request)

   at msa_sn_installer.Main.ImportCustomEntities(String _customizationsFile, CrmService _crmService, Log log, String[] entities) in C:\Documents and Settings\Administrator\Desktop\SocialNetworking_RTW_R1.0\Source Code\Social Networking Installer\msa_sn_installer\Main.cs:line 531.
---------------------------
OK  
---------------------------