Enterprise Search - Unable to Connect to CRM

Nov 11, 2009 at 5:01 PM

I have been struggling with getting this accelerator to function for three weeks now.  Hopefully someone can offer some insight on how to get it working.  

First of all I edited the MSA_MSCRM_BDC_V1.0.xml file.  The only edit that I made was changing the SQL Database name.  I was not sure how to reference the database.  The Database server name = LWGSQL the actual CRM database name = LWG_MSCRM.  With our particular installation of CRM the application is not on the same server as the CRM database.  

<Property Name="RdbConnection Initial Catalog" Type="System.String">LWGSQL\LWG_MSCRM</Property>

 

 Please let me know if I need to reference it differently.  

Nov 11, 2009 at 6:46 PM

I should mentioned that I can upload the XML file to SharePoint perfectly fine.  

Nov 13, 2009 at 5:36 PM

Here are the edits i made to the XML file that came with the search accelerator. 

 

 

Type="Microsoft.Office.Server.ApplicationRegistry.SystemSpecific.Db.DbAccessProvider">SqlServer</Property>
        <Property Name="RdbConnection Data Source" Type="System.String">lwgsql</Property>
        <Property Name="RdbConnection Initial Catalog" Type="System.String">LWG_MSCRM</Property>
        <Property Name="RdbConnection Integrated Security" Type="System.String">SSPI</Property>
        <Property Name="RdbConnection Pooling" Type="System.String">false</Property>
      </Properties>

Type="Microsoft.Office.Server.ApplicationRegistry.SystemSpecific.Db.DbAccessProvider">SqlServer</Property>

        <Property Name="RdbConnection Data Source" Type="System.String">lwgsql</Property>

        <Property Name="RdbConnection Initial Catalog" Type="System.String">LWG_MSCRM</Property>

        <Property Name="RdbConnection Integrated Security" Type="System.String">SSPI</Property>

        <Property Name="RdbConnection Pooling" Type="System.String">false</Property>

      </Properties>

 

Steps:

  1. Upload the XML file under the Shared service administration menu.  The application imported successfully and I can see the entities in my CRM database.  
  2. Under Business Data Catalog on the Shared Services page I clicked Business Data Catalog Permissions.  I made sure that the content source account had full rights to the Business Application.  
  3. Under Search on the Shared Services Page i clicked search settings.  I selected Default Content access account - and set it to an account I know has full rights to the CRM database, this same account i gave full access to in the step above (Settings the Business Data Catalog Permissions)
  4. Then I created the Content Sources to point to My CRM application.  I started A full crawl and here are my results.  
  5. I got to the point where I can search the CRM records on the SharePoint server but not from the desktop client.  I saw a few articles suggesting to use "RevertToSelf" as the security setting however when I try this it only attempts to crawl 17 records instead of the 400k + records it crawls when I leave the permission as pass through. It mentioned that RevertTOself uses the application pool account how do I find out what that is to ensure the application pool account has access to the database.  Also, do you recommend using SSO to fix the authentication issues?  

 

Nov 13, 2009 at 7:32 PM

Dear lord 36 hours of working on this and I finally figured out the RevertToself issues I was having.  My problem was the SharePoint Application Pool account was not a user in CRM and I also had to clear the crawled content from using the passthrough access before I could crawl it again successfully.