Error installing Social Network Acc - Step 8

Nov 20, 2009 at 9:46 PM


during installation of the SN accelerator I'm facing the following error:

System.Web.Services.Protocols.SoapException: Server was unable to process request.
bei System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
bei System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
bei Microsoft.Crm.SdkTypeProxy.CrmService.Create(BusinessEntity entity)
bei msa_sn_installer.Main.UploadReport(String reportFileName, String reportName, String reportDescription, String parentReportId, Int32 categoryCode, String reportObjectTypes, Boolean displayInReportsArea, Boolean displayInForm, Boolean displayInGrid, CrmService _crmService, Log log) in C:\Documents and Settings\Administrator\Desktop\SocialNetworking_RTW_R1.0\Source Code\Social Networking Installer\msa_sn_installer\Main.cs:Zeile 1344.
bei msa_sn_installer.Main.btnInstall_Click(Object sender, EventArgs e) in C:\Documents and Settings\Administrator\Desktop\SocialNetworking_RTW_R1.0\Source Code\Social Networking Installer\msa_sn_installer\Main.cs:Zeile 333.

No more error details in install log or event log on CRM/SQL Server

Machine configuration: CRM 4.0 Rollup 7, fresh installation, no changes made; SQL Server 2008 SP2 on a separate machine

Both CRM and SQL Server are Windows 2008 R2 Enterprise, 64bit, German edition

Any ideas how to track down the issue?

Thanks in advance

Nov 20, 2009 at 9:50 PM

Make sure the user you are connecting with is a System Admin account, or one with enough permissions.

If I run into an error with these installers, I typically just manually install it.... import customizations to CRM, register plugins, etc.

Nov 20, 2009 at 10:02 PM
Edited Nov 20, 2009 at 10:14 PM

Since it's a development environment the installing user is domain administrator, same for credentials provided in SN install form.

Anyway, I found what to do step 9 in the source code, so I will follow your advice of configuring it manually :)

Thank you.



Maybe this is causing the problem? Haven't tried to modify and it re-create setup...

            // Notice that this constructor for CrmNumber is found in the helper code file BusinessEntityPartialTypes.cs.
            r.languagecode = new CrmNumber(1033); // US English

Dec 20, 2009 at 9:09 PM

Mat - did you ever resolve this?  I have the same issue.

Dec 21, 2009 at 7:17 AM

No, haven't actually tried to.

Installing manually went ok, you just to need to create new reports in CRM and select 'Upload existing file' (or something like that), instead of using the Report Wizard.


Dec 29, 2009 at 4:23 PM

Turns out the issue for me is that the reports were created in SQL 2008 and aren't backwards compatible with SQL 2005.  Manually importing didn't work.


There's gotta be a way for me to convert...

Jan 19, 2010 at 11:24 AM

Does anyone have any more news on this on? I have the same issue - failing on the reports step.

Do the other steps get installed and configured/published correctly if the installation package does not complete.  I ask as I configured it and the workflows runs successfully, but I dont see any updates etc in CRM on the user I created.

Jan 20, 2010 at 5:24 AM

The reports are designed for SQL Server 2008 and will not install if you are using SQL 2005. I personally think this is an unfortunate choice because the minimum requirements for CRM are SQL 2005. However, the reports use some of the new charting features in SQL 2008 so I can understand why this was done. Nevertheless, you will not be able to use them if your CRM installation uses SQL 2005.

The setup should complete after teh exception message is displayed, the code uses a try/catch block and proceeds with the installation afterwards. Even if it did not, teh reports are step 8 or 9, step 9 of 9 updates teh ISV.config file, so all you'd be missing is some custom menus and shortcuts, the main mechanisms and custome assemblies would all still be in place.

That said, there are a couple of bugs in the code as supplied that prevent it from working (at least, it did for me). Please see my earlier thread on this topic.


--Tim Long