PRM Accelerator CreateUserAccount Control

Dec 15, 2009 at 2:24 PM

Hi,

I am not sure whether I am just doing something stupid, but I cant for the life of me get the CreateUserAccount control to work correctly.

I have successfully installed the PRM accelerator, and all good, and the test website works as expected. When I have come to setting up users though I am navigating to the CreateUserAccount page and passing in a 4 digit id but all I get is a 'Length of the data to decrypt is invalid'!

I'll be honest and say I have no experience of encryption algorithms, but cant figure this one out.

I've also tried adding in the users using the asp.net configuration tool in the website itself but the ValidateUser call in the Login page always returns false. This is even stranger as if I run a trace on the aspnetdb it correctly fires and returns 0, and the @IsApproved parameter in the sproc is set to 1. The error thats shows back in the website is a simple Authentication error of user name / password incorrect!

Any help would be appreciated.

Thanks

Mike